This project has moved and is read-only. For the latest updates, please go here.

PMU Connection Tester (to SEL351S)

Jan 11, 2011 at 7:20 PM

Hello, I am trying to ensure that OpenPDC can connect to a SEL351S PMU.  I am able to connect to the device via the included SEL programs with the following settings:

2400 BAUD
8 Data Bits
1 Stop Bit
N Parity

Level One Password *****
Level Two Password ***
Serial Connection

TEAM Port 5434
Port 3
Protocol: SEL

15 Minutes to Port Time-Out (T_Out)
N Send Auto Messages to Port
N Enable Hardware Handshaking


However, I am having difficulty connecting to the device with OpenPDC.  Using the PMU Connection Tester with the following settings:

Port: COM3
2400 BAUD
8 Data Bits
1 Stop Bit
N Parity

Protocol: IEEE C37.118-2005
Device ID Code: 1
Configure Alternate Command Channel: Not Defined

I receive the following message:

Awaiting Configuration Frame...

However, the program never returns from this message, and apparently never connects.  Does anyone know what may be missing?  I am concerned that perhaps there should be a password input for the OpenPDC software as well, and that may be the cause.  Or is there some other setting I am missing?  Any help would be greatly appreciated!

Jan 13, 2011 at 9:45 AM

 read the manual for sel351s, specifically the part that describes PMU module. SEL was very into this phasor thing few years ago, and i'am sure they have written nice explanation of PMU part and its settings.

Feb 23, 2011 at 10:13 PM

You probably already figured this out, but you'll want to select SEL Fast Messaging in your PMU Connection Tester, and go in to the extended options and set the data rate to 1 frame per second. The 300 series relays max out at 1 per second - by default, the SEL Fast Messaging in openPDC is set to 20 per second. In the OpenPDC application Manage Devices setting, I had to add the messagePeriod=OnePerSecond to the Connection String parameter.

And keep in mind that if it's an older unit (say, pre-2007?), it may not support synchrophasors at all unless you upgrade the firmware. Plus, you have to have the IEEE 1344 IRIG clock input to get the TSOK target set to 1. Everything depends on that TSOK target being 1.