This project has moved and is read-only. For the latest updates, please go here.

Cannot connect to OpenPDC Windows Service

Jul 20, 2011 at 6:02 PM

Dear all,

I have installed openPDC v1.4.110 on the VM of my computer and consistently its giving me an error 'Failed to connect to openPDC Windows service (Server=localhost:8500;datapublisherport=6165)'

I have read many posts on discussion board for this particular error and tried doing the following things with no success. I can see the openPDC is getting started in the Service utility and also its establishing connection of port on netstat.

 1. CHECK Force IPv4 in system settings and change Manage>Node>Remote Status Service Url = 'server=127.0.0.1:8500;interface=0.0.0.0'

 2. CHECK Force IPv4 in system setting and change Manage>Node>Remote Status Service Url ='server=localhost:8500;datapublisherport=6165'

 3. UNCHECK Force IPv4 in system setting and change Manage>Node>Remote Status Service Url = '( just entered the particulor IPv6 address):8500;datapublisherport=6165'

Along with these above individual  settings I also made consecutive changes in the openPDCConsole.exe.config file in 'value= "(     )" location.

I tried above different configurations and restarted the openPDC form service utility several times. Could you please tell me if there are any other probable solutions which I should try to establish connection to the windows service.

Thank you!!

 

Jul 22, 2011 at 2:07 PM

Try this:

server=localhost:8500;interface=::0;dataPublisherPort=6165

The openPDC may have the service running in IPv6

Oct 24, 2011 at 4:14 PM

Hello,

I have the same problem, specifically with OpenPDC Manager
because with OpenPDC Console and the PMU Connection Tester can stablish a connection and they can process measurement, but OpenPDC Manager is off and said "Failed to connect to openPDC Windows Service (server=localhost:8500;interface=::0;dataPublisherPort=6165)"

I tried different configurations and restarted the OpenPDC form service utility several times
too. The IP configuration is Ok and Port 8500 and Port 6165 are enabled. What Can I do?

I'm working on Windows 7 (32bits).

 

 

Nov 21, 2011 at 8:29 PM

We've fixed an issue related to this recently - do you know which build you are using?

Thannks!
Ritchie