This project has moved. For the latest updates, please go here.

openPDC 1.4 and 1.5 fail in XP, dependency required

Developer
Apr 8, 2012 at 2:36 AM
Edited Apr 8, 2012 at 3:40 AM

ANSWERED:  The Synchrophasor Installers setup.exe application required Microsoft .NET 3.5 Framework.

The following is the case:

I am testing a legacy use case for openPDC on XP using MySQL.   When I run the Synchrophasor Installs setup.exe program, I get an immediate error message: 

Caption:  NET Framework Initialization Error.

Error Message:  Unable to find a version of the runtime to run the application.

Below are the details of the installation.

DETAILS:

The platform is a clean install of Windows XP Professional (x86-32bit) SP2 with the following additional software installed. 

1.   Download and Install .NET 4 Prerequisite Windows Installer 3.1

      http://support.microsoft.com/?kbid=893803

      http://www.microsoft.com/download/en/details.aspx?amp;displaylang=en&id=25

2.   Download and Install .NET 4 Prerequisite Windows Imaging Component (WIC)

      http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=32

3.   Download and Install MySQL Prerequisite Microsoft .NET 4.0 Framework Stand Alone version

      http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

4.   Download and Install MySQL Prerequisite Windows XP Service Pack 3

      Use the Windows Update or download and install from the following URL:

      http://www.microsoft.com/download/en/details.aspx?id=24

5.   Download MySQL Community Edition. Free download. Registration Required.

      http://dev.mysql.com/downloads/mysql/

6.   Install MySQL selecting all of the Custom Installation options (default for Custom Installation).

7.   Run MySQL Workbench and select Manage Connections (bottom left)

8.   Click the Test Connection button (bottom right) to assure that the root password is and connction parameters are correct.

9.  Run Windows Update and install the Windows Update Update.

10.  Activate and assure that Windows passes Genuine Windows compliance.

11.  Run Windows Update and install the Optional update:  Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847) x86

 

Coordinator
May 7, 2012 at 5:44 PM

Thanks AJ. Yes the boot strap installer is a simple .NET application targeting the .NET 2.0 framework. It was our "hope" that most all systems would at least have .NET 2.0 installed.

I suppose we could retarget that small application for C++ or something to make it run on even older platforms - but given the desired target OS is Win2008+, I couldn't see that would be much value.

Thanks for the note / catch!

Ritchie