This project has moved and is read-only. For the latest updates, please go here.

Clone Output Stream

May 11, 2012 at 12:36 AM

Hello,

I would like to broadcast the same SHELBY signal on 3 separate ports.  My understanding of PMUs is limited.  I have openPDC Manager (32bit, version 1.4.210.0, using MS Access) installed and if I navigate to "Output Streams", I see that I can make a copy of the TESTSTREAM.  If I do this and create "MyCopyOfStream" output stream instance, check the "enable" checkbox, and save the output stream, I expect to be able to connect a PMUConnnectionTester instance at the ports I've specified.  However, this is not working.  Below, I've listed the original TESTSTREAM settings compared to the MyCopyOfStream settings.  Everything is in C37.118-2005.

 

Acronym TESTSTREAM
IDCode 235
TCP Channel Port=8900
Nominal Frequency 60
Lag Time 3
Load Order 0
Name Test Stream
UDP Channel Port=-1;Clients=localhost:8800
Frames Per Second 30
Lead Time 1
Enabled TRUE






Acronym MyCopyOfStream
IDCode 235
TCP Channel Port=8901
Nominal Frequency 60
Lag Time 3
Load Order 0
Name MyCopyOfStream
UDP Channel Port=-1;Clients=localhost:8801
Frames Per Second 30
Lead Time 1
Enabled TRUE

 

PMUConnectionTester (version 4.2.12) settings to listen to the MyCopyOfStream are:

UDP.Local Port = 8801

Protocol.Device ID Code = 235

Alternate Command Channel.Host IP = localhost

Alternate Command Channel.Port = 8901

Error:

Attempting connection to "ID 235 using IEEE C37.118-2005 over Udp" at 5/10/2012 4:32:52 PM using IEEE C37.118-2005
Connected to device "ID 235 using IEEE C37.118-2005 over Udp" at 5/10/2012 4:32:52 PM using IEEE C37.118-2005
Exception: Data channel receive exception: The I/O operation has been aborted because of either a thread exit or an application request

 

 

Can you please help?

Thank you ahead of time,

TJ

May 11, 2012 at 1:39 AM

Additionally, I noticed that in the OpenPDC Manager->Real-time Stream Statistics->Output Streams

  • Both TESTSTREAM and my new output stream are green
  •  TESTSTREAM has Run-Time Statistics
  • My stream copy does not appear to have Run-Time Statistics
May 11, 2012 at 2:45 PM

Hi TJ,

When you create a copy of an output stream, the devices, phasors, and measurements that are associated with the original output stream are not copied over to the new output stream. You can manually add those devices to the new output stream using the device wizard (there is a link to the device wizard for each output stream on the output streams page), but there seems to be a bug in v1.4 SP2 where the output stream phasors, analogs, and digitals do not get associated with the correct output stream device.

You can:

  • Go back to the downloads page (http://openpdc.codeplex.com/releases/view/64388) and download the patch labeled "Critical! Output Stream Device Wizard Patch & MS Access Fix". Place the dll in the installation directory for the openPDC (C:\Program Files\openPDC or similar).
  • Manually fix the OutputStreamDeviceID of the phasors, analogs, and digitals in the database after using the device wizard.
  • Switch to the release preview of v1.5 (http://openpdc.codeplex.com/releases/view/76146), in which the bug has been fixed.

FYI, when you add devices to an output stream, you will most likely have to initialize the output stream before the changes take effect.

Hope that helps,
Stephen