This project has moved. For the latest updates, please go here.

Configuring output using OpenPDC Manager

Aug 12, 2014 at 11:06 AM
Hi all,

I'm quite new to PDCs in general and I'm trying to get openPDC set up on a network. I am having some issues with setting up a connection between the output stream and the connection tester.

After installing OpenPDC manager, there is a output stream called "TESTSTREAM" for the Shelby input. I am testing how I can send data across the network by trying to use the PMU connection tester to see if I get a feed from "TESTSTREAM".

Currently, I am getting a connection but not any data. I understand there is another thread on this topic already which was solved by using IPv6. However, the network that I have is I think is a private IPv4 network.

Here is a screenshot of what I'm seeing:
Image
Coordinator
Aug 12, 2014 at 2:41 PM
Hello YuchenW,

To force IPv4 in the openPDC, use the openPDC Manager to configure it. Refer to the following image.

Image

After modifying the TCP Channel and UDP Channel, don't forget to click the "Save" button, and then use the "Initialize" button to initialize the adapter.

Next, in the PMU Connection Tester, refer to the following image.

Image

Once you have properly configured the connection in the PMU Connection Tester, click the "Connect" button and you should see data flowing shortly.

Thanks,
Stephen
Aug 13, 2014 at 10:38 AM
Edited Aug 13, 2014 at 10:39 AM
Thank you very much Stephen.

Following all of that, I now can get the data from "Shelby". I've now tried to do this on two machines on the network, and it works like a charm!

I now have a slightly different issue. I have one of the computers hooked up to a MICOMP847, and I'm trying to do exactly the same thing.
From the PC I'm on, I'm able to connect to MICOMP847 and produce a output stream which I can pick up using the Connection Tester. However, when I try to pick up the output stream on another machine on the network, I get the following:

Image

Would you be able to help me with this error?
Aug 14, 2014 at 11:00 AM
Okay, so I decided to set up the second machine again from scratch.

I have not been able to get any kind of feed whatsoever from the PDC Output Stream on the second machine. However I can get The Output Stream from Shelby. Any tips?
Coordinator
Aug 20, 2014 at 5:30 PM
All I can think to do is try to walk through a scenario. Let's say I have set up the openPDC on system #3 (192.168.1.3), and I would like to receive the data stream via UDP on system #7 (192.168.1.7).
  1. On system #3, use the openPDC Manager to configure the UDP Channel to send to 192.168.1.7:8800. It should look something like "Port=-1; Clients=192.168.1.7:8800; Interface=0.0.0.0". Don't forget to click "Save" and "Initialize".
  2. On system #3, configure Windows Firewall such that it is either disabled or allows traffic to TCP 8900.
  3. On system #7, configure Windows Firewall such that it is either disabled or allows traffic to UDP 8800.
  4. If you have another firewall between #3 and #7, it will need to be configured to allow traffic to TCP 192.168.1.3:8900 and UDP 192.168.1.7:8800.
  5. On system #7, run the PMU Connection Tester.
  6. Click the UDP tab and enter 8800 as the Local Port.
  7. Click "Configure Alternate Command Channel". Enter 192.168.1.3 as the host IP and 8900 as the port. Click "Save".
  8. Click "Connect".
As for the errors you were receiving in the PMU Connection Tester, it appears as though there may have been some data corruption, or perhaps there was another stream of data being sent to UDP 8800 on that system.

Thanks,
Stephen