This project has moved and is read-only. For the latest updates, please go here.

Cannot Connect to OpenPDC Service due to Authentication Failure

Nov 23, 2015 at 8:35 AM
Edited Nov 23, 2015 at 8:37 AM
After I installed Openpdc, the openpdc service starts OK. But the Openpdc manager cannot connect to the service. And I tried to run Openpdc console and it gives
Exception during connection attempt: Unable to authenticate connection to server: The remote certificate is invalid according to the validation procedure.
So I looked into the error log and it records
Exception Source: System
Exception Type: System.Security.Authentication.AuthenticationException
Exception Message: Authentication failed because the remote party has closed the transport stream.
Exception Target Site: EndProcessAuthentication
The OS is Windows Server 2008 R2, and I have successfully run Openpdc on another machine with the same OS, so I guess there must some tweaks to be done on this machine.

I choose to use sqlite as the openpdc database.

Any suggestion is appreciated.
Nov 23, 2015 at 2:56 PM
Looks like you may not have rights to the database.

I would suggest re-running the Configuration Setup Utility and walking through the setup where you use an existing database as-is and let it attempt to properly reestablish security for your user account.

Nov 23, 2015 at 9:51 PM
Edited Nov 23, 2015 at 9:52 PM
Hello Ritchie,
Thanks for your reply. I have done as you suggested several times but unfortunately it still doesn't work. Since I have done the same procedure on another computer and it works well and the unsuccessful computer is pretty clean with only .Net 4.5 installed, I am guessing maybe this computer lacks something.

I searched "The remote certificate is invalid according to the validation procedure" on google and people are talking about certificates so I imported all the certificate from the successful computer but got no luck. Can you think of any other system prerequisite that may be needed?

Nov 24, 2015 at 2:53 PM
Couple of things to try (1) with the service not running, delete the openPDC.cer file then restart the system, (2) make sure all the patches for Windows Server 2008 R2 are up to date.

Alternately you can try to reduce your TLS version since you are using an older operating system, e.g., TLS 1.1 instead of the default TLS 1.2 - you can change this in the openPDC.exe.config file. Note that if you cahnge this, these system settings must match for the manager and the console as well.