This project has moved. For the latest updates, please go here.
2

Closed

Configuration tool 'Test Database Connection' errors are vague

description

In setting up a database in Configuration Setup Utility, the 'Test connection' error messages are vague. A generic 'Database connection failed' error appear when the assembly to connect to the database is not locatable, leading to unnecessary confusion and wasted time in trying to debug connection strings.
 
(Tested when attempting to use a MySQL database, but without the assembly available)
Closed Apr 21, 2016 at 2:50 PM by ritchiecarroll
Move to future web based UI feature requests

comments

ajstadlin wrote Apr 8, 2012 at 4:25 AM

I think this may be related to the discussion topic: Wiki Link: [discussion:257742]. After correcting the assembly version in the Advanced dialog, I get similar confusing "... cannot find the file specified"
Confusing because no file is specified.

Exact error:
Checking if database openPDC already exists.
Attempting to run openPDC.sql script...
The system cannot find the file specified
Operation failed. Click the back button to try again.

Tested with openPDC 1.4 SP2, 1.5, and Nightly build 1.5.74. MySQL current version 5.5.22.1, Network Connector version 6.4.4 (installed by the MySQL installer). Platform tested: XP Pro/32 with SP2 Clean Install, SP3 installed, .NET 4.0 extended (full) installed, .NET 3.5 SP1 installed (required by the openPDC 1.4 installer). Installed in a VirtualBox virtual machine (for legacy support test case).

I think it is probably a simple technical issue like the MySQL 5.5.22.1 installation not creating its "my.ini" file.
It would be nice to resolve this as this problem has stopped me in my tracks for openPDC on XP with MySQL.

wrote Jul 23, 2012 at 12:15 PM

wrote Feb 21, 2013 at 11:50 PM

ritchiecarroll wrote Oct 22, 2013 at 5:20 PM

Is this still as issue?

wrote Apr 21, 2016 at 2:50 PM