This project has moved and is read-only. For the latest updates, please go here.

OpenPDC configuration using openPDC Manager: Database Update Failed

Jun 17, 2010 at 3:16 PM

Hello Folks,

This is Vinodhkumar Raja, Graduate Student @ NC State University. I am a novice in using openPDC, seeking your expert suggestions.

I am trying to simulate a PMU Device using a C# program and configure openPDC to receive the time-series data (IEEE c37.118 Format) from my PMU Simulator. The configuration is successful and the communication is working fine when I manually do the configuration by updating the Access Database. But when I use openPDC Manager to configure, the following error is thrown.

1. Device Configuration Wizard:

openPDC Manager Error Occured!  "Failed to Save Configuration Information" : The creator of this fault did not specify a reason

2. Manage Output Streams:

openPDC Manager Error Occured!   "Failed to Save Output Stream Information" : Operation must use an updateable query

These are just 2 instances and the error is thrown whenever I edit someting and try to save the info. The openPDC.mdb file properties looks good to me.

My Setup Details:

openPDC: Tried both Stable release v1.0 as well as the latest nightly build. (installers)

OS: Windows XP

Database: Buit-in Access DB

I have read through the docs and searched in the openPDC discussion forums for any probable resolution. But could not figure out the cause of the error.  Please provide your comments/suggestions to resolve this issue. I would be glad to provide more information if needed.

Thank You,

Vinodh

Jun 17, 2010 at 4:27 PM
Hi Vinodh, Thank you for trying out openPDC. Few things to check here. 1. Make sure openPDC.mdb file is not read-only. 2. Check ErrorLog table in the database to see if it has any records. If so, then please let us know. If above does not help, then make sure the following built in user accounts have write permission to openPDC.mdb file. 1. On Windows 7 OS with IIS7: IUSER and IUSER_MachineName if exists. 2. On previous versions of Windows or IIS: ISUER_MachineName and ASPNET Please let me know if this helps or not. Thank you, Mehul Thakkar
Jun 17, 2010 at 7:00 PM

Hi Mehul,

Thanks a lot for your response. I did all this except the write permission for ASPNET user. Even adding ASPNET user also didnt help to resolve the issue. On the otherhand, now when I open the openPDC Manager, it is just saying "Loading Data... please wait.." and waiting infinitely. I re-installed openPDC Manager again and then did all the configuration, security settings etc.  But again says "Loading Data... please wait.." I do not understand what went wrong.

More Info:

- I am using IIS 4.0.

- I have installed openPDC in the default path "C:\Program Files\TVA\openPDC".

Thanks,

Vinodh

Jun 17, 2010 at 8:15 PM

Hi Vinodh,

I assume you have it installed on your local machine. Please try to go to http://localhost/openPDCManagerServices/Service/PhasorDataService.svc url. If everything is set up correctly, you should see a page which says "You have created a service". If not, then something is wrong with the web service which retrieves data from the database and sends to silverlight UI. Please make sure MIME type for .svc file is registered (Open the command prompt and type "%windir%\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\ServiceModelReg.exe" -r -y).

You should be able to click "x" button on the top right corner of the "Loading Data... please wait..." window. Then try going to any other page (e.g. Manage --> Node) and see if that works. I would also recommend using nightly build as we have added lot more features after initial 1.0 release.

Please let me know if this helps or not.

Thank you,

Mehul Thakkar

 

Jun 18, 2010 at 3:08 PM
Edited Jun 18, 2010 at 4:12 PM

Hi Mehul,

Thanks for the information. I have re-installed the openPDC, PMU Connection Tester & Manager.  [openPDC and Tester working fine]. Then I opened the Manager and tried to edit and save node configuration information and it was succesfully updated. Then when I return to homepage or reload , it keeps on saying "Loading Data.. Please Wait" and when I hit the "X" button, it do not show the vendor device distribution pie chart and real-time graph in the homepage. I have configured the real-time data and remote monitor url properly. I did not face this problem with the stable release. Now, I'm using the nightly build downloaded on Jun 15th 2010.

Then I tried to go the other pages and got the below error,

Failed to Retrieve companies: or Failed to Retrive Node List: or Failed to Retrive Device List: with following debug info;

openPDC Manager Error Occured! 'could not use"; file already in use.'

(or)

"[HttpWebRequest_WebException_RemoteServer]
Arguments: Not Found
Debugging resource strings are unavailable.often the key and arguments provide sufficient information to diagnose the problem."

I could not see the DB file is opened by any application, except the browser running the openPDC Manager. I'm suspecting that the Access DB is opened in some shared mode between ASPNET and IUSR_machinename users and the problem could be due to shared access between these user accounts. Does it make sense? Please let me know your view on this issue.

Thank you,

Vinodh

 

 

Jun 18, 2010 at 4:32 PM

Hi Mehul,

Thanks for the help! Finally the issue is resolved! The problem is due to the fact that Access DB file is under "C:\Program Files\TVA\openPDC\openPDC.mdb".  Copying this file outside the "Program Files" folder and configured the openPDC Manager to use it, helped. I am just curious to know, if anyone has faced this issue and resolved this way in the past.

Thank you,

Vinodh

Jun 18, 2010 at 5:22 PM

Hi Vinodh,

That's interesting. I will keep this in mind for future. I'm glad it worked out for you. Please let us know if you have any questions or suggestions.

Thanks,
Mehul Thakkar

Jun 18, 2010 at 7:15 PM
Edited Jun 18, 2010 at 7:21 PM

Windows 7 treats the programs folder as protected - you cannot read or write to this folder without Admin access.

 

Thanks!
Ritchie

Jun 21, 2010 at 3:13 PM

Hi Ritchie,

Thanks for the info. I did read this from the docs. But it does not affect me, since I am working on Windows XP.

Now, I have another question. My PMU simulator program is able to communicate with the openPDC. I could see the data, config info that is sent from my PMU program via System Monitor option.

But the real-time graph is not getting displayed. I did get this graph before this latest re-installation.

Thank You,

Vinodh

 

Jun 21, 2010 at 4:07 PM

Hi All,

Solved! Its a configuration error. I forgot to update the the new location of the Access DB in the ADOMetadataProvider's connection string.

Thanks,

Vinodh

Jun 30, 2010 at 1:15 AM
Edited Jun 30, 2010 at 1:16 AM
Hi all, I have a question on open PDC Manager when I open the openPDC Manager, it is just saying "Loading Data... please wait.." and waiting infinitely. And when I try to add another device after clicking the small x sign,since it is still processing it showing me the error openPDC Manager Error Occured! 'could not use"; file already in use.' I tried the above suggestion but it didn't work out for me. I registered the svc file and also changed the mdb file location.but nothing is working so far. please help me. regards, RAM Mississippi State University
Jul 7, 2010 at 5:44 PM

Hi Ram,

Please check if http://localhost/openPDCManagerServices/Service/PhasorDataService.svc url is working as mentioned above. Also make sure access database file is not locked. Please let me know if this helps.

Thank you,
Mehul Thakkar

Jul 7, 2010 at 5:58 PM
Hi Mehul,

I solved that problem by providing the security access for database file and the PDC is working now,
 but now the major problem is I am not able to get data into the OPEN PDC manager even though I added the PDC devices and it just staying blank not displaying real time information.

I have an SEL -3306 PDC which is receiving data from SEL -421 PMU.

regards,
RAM

On Wed, Jul 7, 2010 at 11:44 AM, mthakkar <notifications@codeplex.com> wrote:

From: mthakkar

Hi Ram,

Please check if http://localhost/openPDCManagerServices/Service/PhasorDataService.svc url is working as mentioned above. Also make sure access database file is not locked. Please let me know if this helps.

Thank you,
Mehul Thakkar

Read the full discussion online.

To add a post to this discussion, reply to this email (openpdc@discussions.codeplex.com)

To start a new discussion for this project, email openpdc@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com




--
RAM MOHAN,REDDI
Graduate student
Electrical Engineering
Jul 7, 2010 at 6:12 PM

Please check the Time Series Data Service URL and the Remote Status Service URL on the node screen:

http://openpdc.codeplex.com/wikipage?title=Manager%20Configuration&referringTitle=Documentation#create_first_node

These must point to an active instance of the openPDC.

Thanks!
Ritchie

Nov 24, 2010 at 12:59 AM

Hi Vinod,

I am Graduate Student. I am interested in simulating the PMU... How did u simulate the PMU? Which simulator do you use for that?

 

Regards,

Graduate Student

Electrical Engineering