This project has moved. For the latest updates, please go here.

Instalation Issues with 1.1 and Server 2008

Jul 7, 2010 at 3:23 PM

I used the instalation pacakages to do a clean install.

DB reated properly, console works well adn even bringing indata from the file based sample PMU.

However when I try to use the web manager it will not connect to the DB.  I get a crossdomain error from phasordataservices.

I have pured through configuration file and cannot find any DB mismatches. Any ideas where to look next?

 

Scott

Coordinator
Jul 7, 2010 at 4:21 PM
Edited Jul 7, 2010 at 4:32 PM

Hi Scott,

The error you are describing is briefly mentioned on the FAQ page.

http://openpdc.codeplex.com/wikipage?title=FAQ#cross_domain_error

The clientaccesspolicy.xml file is located in "C:\Inetpub\wwwroot\openPDCManagerServices" by default.

Please move that file up to "C:\Inetpub\wwwroot" and try again.

Thanks,
Stephen

Jul 7, 2010 at 4:29 PM

Thanks for the reference point Stephen, but that does not fix my issue.  I already had the file at the wwwroot level.   But I did copy and then move the file from the ...managerservices and it made no change.

This cross domain error is different than one I had with previous version.  This one is saying it "failed to retreive companies" followed by two more "failed to receive node list and then failed to receive node.

Scott

Developer
Jul 7, 2010 at 4:36 PM

Hi Scott,

Please check if the following url returns "You have created a service" message.

http://localhost/openPDCManagerServices/Service/PhasorDataService.svc

Also make sure you have updated "BaseServiceUrl" setting in the web.config file for openPDCManager folder.

What database are you using (mySQL/Access/SQL Server)?

Please let us know if this helps or not.

Thank you,
Mehul Thakkar

Jul 7, 2010 at 4:49 PM

 

Thanks Mthakkar for the response. 

I do get the ""You have created a service" message" from phasordataservice.svc

I did not modigy the web.config file (loved the new instalation packages with 1.1 btw)

  <add key="BaseServiceUrl" value="http://localhost:1068/" /> is what it was set to.  I have tried changing this to the IP address of the machine with no impact

MySQL with instance created by new instalation scripts.  I created it from scratch just so that I would be les likely to haev issues instead of converting from my old DB

Coordinator
Jul 7, 2010 at 4:53 PM

Hi Scott,

Instructions on changing the BaseServiceUrl are also available on the FAQ page.

http://openpdc.codeplex.com/wikipage?title=FAQ#openpdcmanager_installer

Thanks,
Stephen

Jul 7, 2010 at 9:15 PM

Thanks Staphen, that did the trick.

Also had to change the password in web.config but then it let me in.

Thanks so much for the help today

scott