This project has moved and is read-only. For the latest updates, please go here.

Almost there, need configuration assistance

Feb 23, 2011 at 4:54 PM

Howdy all,

I've read the FAQ, the Wiki, searched the Wiki, etc... But still, I don't get any real time display of data in the openPDC Manager.


My test setup is an SEL-311C (recent vintage), SEL-2030, Arbiter GPS clock, and a laptop running Windows XP SP3 that's serially connected to the 311C, with an Access database.


I installed OpenPDC using the Windows installer package. Went smoothly. I've run the PMU Connection tester, it sees my 311C just fine and gets data. I've got the openPDC Manager configured with the device, the device status light is green, and the Statistics show that I am receiving 1 frame per second (the max rate for a 311C, unfortunately). I've poked and prodded my openpdc.exe.config file until it's begging for mercy... I've got a Historian set up, tried with and without something in the ConnectionString field, have tried modifying the historianADOMetadataProvider by adding my Access database in the connection... but nothing.


I figure there's some subtle thing I'm missing. Any ideas would be appreciated.


Once this is working, I plan to grab some more relays (a 421 or 487V) and do more experimenting.

Feb 23, 2011 at 5:57 PM

Can you provide the following openPDC Manager screen shots please to let us have a look?

1.  Input Status Monitor with all levels on the left side expanded

2.  Manage Devices - showing the device you configured

3.  Manage Measurements - showing the PPA Measurements

4.  In Manage Devices for your device, please execute the "Initialize" the device by clicking the "Initialize" link.  Then switch to the Monitoring/System Console display.  Please provide a screen shot of the results that include the [device_name] in brakcets lines for Initialize or Reset.  Look for "WARNING" messages that may be related to device name or ID that may not match the configuration.

Is your setup using IEEEC37-118 or different protocol?



Feb 23, 2011 at 7:32 PM
Edited Feb 23, 2011 at 9:28 PM

Thanks for the reply. Well, a little while ago I decided to wipe it all out and reinstall OpenPDC. And guess what... Yup, it's working now. :)

Though with my most recent installation, I think I did everything in the right 'order' this time. Previous installation was likely configured out of order. I suppose with my first attempt, I think I configured the Input Device before the Historian... this time, I followed the order of the guide and set up my device, my company, the Node, Historian, and THEN the device. I did have to tweak the openPDCManager.exe.config file and remove the references to SQL Express and enable the MS Access database - and point to my database location in the ConnectionString. Also had to tweak opePDC.exe.Config to point to my database in the ConnectionString as well. But other than that, no config file manipulation.

I'm using the SEL Fast Message for the protocol.

Thanks again though. I'm off and running, time to find some more relays, and work on getting approval to put this in a substation. :)

Edit: Looks like sometimes the graph (on Input Status & Monitoring) will just 'stop', and doesn't want to restart. Something weird happening there.