This project has moved and is read-only. For the latest updates, please go here.

Can't log in to OpenPDC Manager after install

Mar 22, 2011 at 6:57 PM

Hi.  I've got a slight variation on the "can't log into OpenPDC manager" situation.

I get the error message:  Error loading security provider : Invalid object name 'UserAccount'

I tried the work around for using integrated security with no outward effect.


Mar 22, 2011 at 7:11 PM
Edited Mar 22, 2011 at 7:41 PM

This sounds like a database issue - does the UserAccount table exist?

Also are you using a VM or real hardware?

Mar 22, 2011 at 7:50 PM

I'm using real hardware... which just failed.  I can't verify that the UserAccountTable exists until I get the hardware repaired (memory failure).

One clue:  I'm using an existing database that worked with the previous version of the OpenPDC.  (I'm updating to the newest release of the OpenPDC.)

Thanks for the help.

Mar 22, 2011 at 8:10 PM

Great - just walk-through upgrading your existing database in the "Configuration Setup Utility" (i.e., select "I want to use an existing configuration", "Database" and "I want to upgrade to the latest schema") and you should be good to go.


Mar 22, 2011 at 10:59 PM


I reinstalled the OpenPDC and asked it to upgrade our existing database.  That didn't quite get things going.  Now I receive "Access Denied.  You do not have permission to access the requested secure resource."

It's recognizing the credentials (Windows administrator login and password) as valid (i.e. it complains if I give it the wrong password).  I just do not have sufficient permission to run the OpenPDC Manager.

The UserAccount table exists but is empty.

What do you suggest?

Mar 23, 2011 at 4:52 PM

I would have expected that during the upgrade to the latest version that the system would ask for a user name and password. When you walked through the "Configuration Setup Utility" and selected I want to upgrade to the latest schema the wizard should have prompted you to create a new database. Then upon inspection of the old database, the wizard would have detected that the AuditLog table did not exist so this is an upgrade from a version without security to a version that has security and it would prompt you for a default/initial admin user name and password. The fact that this table wasn't populated leads me to believe that you did not get prompted for this information. Did you see a screen asking for default username and password? Are you using a local database server?


Mar 23, 2011 at 6:13 PM


I didn't see the screen asking for defaut username and password.  I tried the upgrade again this morning (after deleting the database) with the same results.  No dialog and no access to the OpenPDC Manager.

I then tried upgrading but creating a new configuration.  This time I saw the default username/password dialog.  And... I can run the OpenPDC Manager.  Of course, I've lost all my previous settings.

Is this an unintended way of saying that a clean start is in order?  (It's probably a very good idea in my case!)

Thanks for the help.


PS.  I realize that I may have created havoc by deleting the database without editing any of the OpenPDC configuration files.  Such is life!