This project has moved. For the latest updates, please go here.

The Historian PlayBack Utility Program not work

Mar 30, 2011 at 7:22 PM

I'm working on the project Medfasee at the Federal University of Santa Catarina. About one month ago, we were using the latest version of OpenPDCManager, receiving data from14 PMUs and storing them in the default database (Historian). The program works perfectly, receive, send, stores and shows graphics in real time.
But I have a problem with the PlayBackUtility program, clicking the start button or close it stops to work.
Showing the message: "An unhandled exception occurred in the application" and recommends to perform a debugging Just-In-Time (JIT).  This error always occurs. I tested this application on both Windows XP and Windows 7-64Bits.

Can anyone help me?

Thank you

Coordinator
Mar 30, 2011 at 7:55 PM
Edited Mar 30, 2011 at 7:56 PM

Have you tried running the application as administator? You can do this by right clicking the "Historian Playback Utility" shortcut in start menu, selecting "Properties", clicking the "Compatibility" tab, then checking the "Run the program as administrator" check-box. Or, if you browse to the folder containing the EXE, you can right click on it and select "Run as Administrator".

Some of the config file settings may be missing - running the app as admin will add the needed keys. This may only need to be done once.

You can verify these settings manually, here are the necessary historian playback utility config file settings:

<?xml version="1.0" encoding="utf-8"?>

<configuration>

  <configSections>

    <section name="categorizedSettings" type="TVA.Configuration.CategorizedSettingsSection, TVA.Core" />

  </configSections>

  <categorizedSettings>

    <lastWindowSize>

      <add name="Main" value="" description="Size of the windows form." encrypted="false" scope="User" />

    </lastWindowSize>

    <lastWindowLocation>

      <add name="Main" value="" description="Location of the windows form." encrypted="false" scope="User" />

    </lastWindowLocation>

    <general>

      <add name="Selection" value="" description="" encrypted="false" />

      <add name="ArchiveLocation" value="" description="" encrypted="false" />

    </general>

  </categorizedSettings>

  <startup>

    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>

  </startup>

</configuration>

The config file is normally installed at this location: C:\Program Files\openPDC\HistorianPlaybackUtility.exe.config

In order to correct these settings, you will need to run notepad (or other text editor) as admin.

Ritchie

Mar 30, 2011 at 9:58 PM

Hi 

I did the modifications described, but still not work the program.

First I ran the application as administator. Unsuccessfully.

After, I edited the configuration file (HistorianPlaybackUtility.exe.config). I copied and pasted the source code, previously described there. Unsuccessfully too.

There is another possibility for solution this problem
Thank you your attention

Paulo André

Coordinator
Mar 30, 2011 at 11:29 PM

What is the exact version of the openPDC you are using? On the top Window of the openPDC Manager you should see a version.

I recommend using the latest release, 1.4.90, if that is not the version you are using.

Ritchie

Mar 31, 2011 at 12:11 PM

Hi Ritchie
I'm using the version 1.4.90 of OpenpPDCManager and v1.1.50 of the Historian PlayBak Utility.

Thank you

Paulo André

Coordinator
Mar 31, 2011 at 12:52 PM

Those are the correct versions. What is your Windows OS language?

Mar 31, 2011 at 1:23 PM

I'm using Windows 7 64Bits - Portuguese Brazil

Mar 31, 2011 at 5:01 PM
Edited Mar 31, 2011 at 5:06 PM

Hi Ritchie
I did changes in the linguage of my Windows and the program be working.

Put language - English (United States)
Thank you Ritchie

Coordinator
Mar 31, 2011 at 5:53 PM

Good deal. Likely related to English formatted dates internally, we'll add this to the task list for this tool.

Coordinator
Mar 31, 2011 at 5:57 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.