This project has moved. For the latest updates, please go here.

Can't configuration OpenPDC with mysql.

May 16, 2011 at 8:28 AM
Edited May 16, 2011 at 8:31 AM

Hi all !

 

i try to install OpenPDC with mysql database but it occur the problem like following:

Checking if database openPDC already exists.
Attempting to run openPDC.sql script...
The system cannot find the file specified
Operation failed. Click the back button to try again.

My system: windowsxp SP2, OpenPDC 1.4, mysql 5.1.3

Please help me to fix this problem.

Thank in advance !

Developer
May 18, 2011 at 1:33 PM

Hi,

 

Interesting. I assume you have re-downloaded the latest installation files and tried to install it again?

 

Developer
Apr 8, 2012 at 4:58 AM
Edited Apr 9, 2012 at 3:52 AM

I am trying MySQL and openPDC for the first time.  I have the same issue described above.  XP Pro/32 SP3, MySQL 5.5.22.1, Net Connection 6.4.4.

The error is the same for both openPDC 1.4 SP2 and for openPDC 1.5.

I also get this error with the openPDC Nightly Build 1.5.74

To get openPDC 1.4 to "Test Connection" work, I had to set the Assembly Connection String to "6.4.4".  This is already set in openPDC 1.5.

WORK-AROUND

The problem is the method used for finding the path to MySQL executable for running the SQL scripts in the  in the constructor code in *\Synchrophasor\Current Version\Source\Tools\ConfigurationSetupUtility\MySqlSetup.cs.

One work around is to create the Registry Setting for the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MySQL\ImagePath

Then copy the value found in the HKLM\SYSTEM\CurrentControlSet\services\MySQL5\ImagePath to the MySQL\ImagePath.

The value I have after installing MySQL 5.5.22.1 is:

"C:\Program Files\MySQL\MySQL Server 5.5\bin\mysqld" --defaults-file="C:\Documents and Settings\All Users\Application Data\MySQL\MySQL Server 5.5\my.ini" MySQL55

Another possible work around might be to add "C:\Program Files\MySQL\MySQL Server 5.5\bin" to the Environment PATH.

ajs

Coordinator
May 7, 2012 at 5:45 PM

Hopefully this has been corrected in the later builds - let us know if not.

Thanks!
Ritchie

Jun 7, 2012 at 4:16 AM

Hi all:

I´m trying to configure OpenPDC with MySQL database but it occur the problem like following in the  window "Set up in progress" when I´m runing the "Configuration Set Up Utility" :

Checking if database openPDC already exists.Could not load file or assembly 'MySql.Data, Version=6.3.6.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d' or one of its dependencies. The system can not find the file specified.Operation failed. Click the back button to try again.

My system on 64 bits:

Windows7 Home Premium

openPDC v1.4 SP2 Release,

mysql 5.1.63

Please help me to fix this problem.

Developer
Jun 7, 2012 at 1:07 PM

1. Have you installed the MySQL Connector NET?

2. While running the configuration setup utility

From the welcome screen select 'Next'

Select 'I want to set up a new configuration'. Click 'Next'

Select 'Database'. Click 'Next'

Select 'MySQL' & 'Run initial data script'. Click 'Next'

Host name = 'localhost', Database name = [pick-a-name]; Admin user name: 'root'; Admin password: [your password from the MySQL install]. Click 'Next'

Verify by clicking 'Test Connection'. This is probably where you are having a problem.

If you get an error (the connection test is negative) then click 'Advanced' and change the 'Version' in the Data Provider String to the

same version number of the MySQL Connector NET that you installed on your machine.

This should solve your problem.

Otherwise, repost and let me know

Kevin

Jun 22, 2012 at 9:30 PM

Hello, people. I was having the same problem, and solved it changing the version in the Data Provider String, like Kevin said. Thanks!

Jul 3, 2012 at 1:47 PM

kevinjones,

Thanks for your tip!

I have spent a long time with this!!! But now it's working!

People with the same problem, do what kevin said... This realy works!

Tanks again