This project has moved and is read-only. For the latest updates, please go here.

AdoAdapter dump unprocess measurement in the output queue.

Dec 29, 2011 at 4:06 AM

Hi everybody !

I installed the OpenPDC v1.4 SP1 (1.4.110) 64 bits on Windows 7 64 bits.

The OpenPDC can receive configuration and data from the PMU. i configured the AdoAdapter to save data to mysql database and it work well, but when i open the OpenPDC consolse i see that "[Adoadapters] there are xxxxxx unprocessed measurements in the output queue"  (xxxxxx is the number of unprocessed measurements) when the number of the unprocessed measurements is 500000 the output queue is dumped (the OpenPDC consolse alert that " [Adoadapters] system exercised evasive action to converse memory and dumped 500000 unprocessed measurements from the output queue :( "

Please help me to solve this problem.

Thank in advance any help.

 

GiaLong

Dec 29, 2011 at 3:45 PM

This is typically indicative of a connectivity issue to the database - can you provide the connection string? FYI, here are a couple of good links to discussions you can review for understanding how to properly setup and use the AdoOutputAdapter:

Thanks!
Ritchie

Dec 30, 2011 at 10:54 AM

Thank you so much for your reply, Ritchie !

i did like your suggestion and the OpenPDC can save data to the table of mysql. it work well with SHELBY but when i connect the OpenPDC with real PMU the problem appear like i posted above. ( it's seem that the AdoAdapter is not enough speed to save all data to mysql table).

i'm using AdoAdapters

The configuration:

  • Adapter Name: AdoAdapters
  • Node: DefaultAssembly Name: AdoAdapters.dll
  • Type Name: AdoAdapters.AdoOutputAdapter
  • Conncection String: tableName=adapt;IDFieldName=ID;TagNameFieldName=TagName;SignalIDFieldName=SignalID;SourceFieldName=Source;TimestampQualityIsGoodFieldName=TimestampQualityIsGood;ValueQualityIsGoodFieldName=ValueQualityIsGood;TimestampFieldName=Timestamp;ValueFieldName=VALUE;timestampFormat=yyyy-MM-dd HH:mm:ss.fff;dbconnectionString={server=localhost;database=openpdc;uid=root;pwd=''};dataProviderString={AssemblyName={MySql.Data, Version=5.2.7.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d}; ConnectionType=MySql.Data.MySqlClient.MySqlConnection; AdapterType=MySql.Data.MySqlClient.MySqlDataAdapter}

Please tell me what is the problem with this configuration ?

can you suggest me to configure with MySqlAdapters, Please !

Thank in advance any suggestion.

GiaLong

Mar 27, 2012 at 8:31 PM

Did you ever get this working?

Thanks!
Ritchie

Mar 28, 2012 at 8:31 AM

Hi Ritchie !

i tried to use AdoAdapters to put data of 26 PMUs to one Adapter/one adapt table => the problem with "unprocessed measurement" appear.

then i tried with the AdoAdapters by other way:

i created one adapt table per one Adapter per one PMU. i have 26 PMUs so i created 26 Adapters and 26 Adapt tables when the PMUs working at 50 frames/second the OpenPDC used 100% CPU loading( with the structure: one machine to run the OpenPDC then send data to mysql DB on another machine. the OpenPDC machine used 100% CPU loading and the mysql machine used about 80% CPU loading).

so i have to find another solution with my system.

Thank you, Ritchie.

GiaLong

Mar 28, 2012 at 2:07 PM

A database is generally not a good choice given the volume and speed of synchrophasor data.

The built-in historian is better suited to store the data... From your other post - looks like you are exploring this option.

Good luck!

Thanks!
Ritchie