This project has moved. For the latest updates, please go here.

Connecting openPDC to openPG

Developer
May 21, 2012 at 7:02 PM

I would like to connect an instance of openPDC to openPG. Both are running on the same machine. I have looked into the "How-To"section on the openPG website but to no avail.

Anyone have any experience with this and could guide me in the right direction?

Thanks,

Kevin Jones

Developer
May 22, 2012 at 11:34 AM

Certainly, we should be able to help with this.

How are you wishing to connect openPDC and openPDC? Are you wishing to forward the data from openPDC to openPG, or vice versa? Also, are you wanting to forward all data, or only some?

Developer
May 22, 2012 at 11:45 AM

Yes, I would like to be able to forward the data from openPDC to openPG and yes, I would like to be able to forward only a subset of the data that I have inside of openPDC.

I do have a simulated data source connected to openPDC.

Thanks in advance for your help!

Kevin

Developer
May 22, 2012 at 12:20 PM

The most direct way of forwarding some data from openPDC to openPG would be an output stream. The instructions on the openPG How-To are primarily for forwarding all data.

In openPDC Manager, create a new output stream, and add whatever devices/measurements you wish to share. Then, in openPG, add that stream to receive the data.

Developer
May 22, 2012 at 2:02 PM

Its the latter that I am having trouble with...What are the specifics of then adding that stream in openPG to receive the data?

Kevin

Developer
May 22, 2012 at 3:05 PM

Do you already have the openPDC output stream configured? Typically, a new connection can be created by using the Input > Device Setup Wizard. If you have connected to the stream with the PMU Connection tester, you can just open that file, or you can input the connection string manually.

Developer
May 22, 2012 at 3:17 PM

I have not successfully used the PMU Connection Tester to connect to the output stream of the openPDC. I would like to do it that way. That way will be easier to reproduce for others.

My output stream:

Acronym: MAINSTREAM
Name: Main Output Stream
Type: IEEE C37.118
ID Code: 240
TCP Channel: port=8950;transportprotocol=tcp;interface=0.0.0.0
UDP Channel: port=-1;clients=localhost:8850;interface=0.0.0.0

All appropriate boxes are checked/unchecked.

The output stream is enabled.

on the PMU Connection Tester side:

TCP
Host IP = 192.168.113.142
Port = 8950
Device ID Code = 240
IPv4 is forced true.

Cant make a connection to the openPDC. I know how to generate the configuration and pmu connection files if I can make a connection. Then I know how to add the new device to the openPG.

Kevin

 

Developer
May 22, 2012 at 3:17 PM

IP: 127.0.0.1 does not work either

Developer
May 22, 2012 at 3:46 PM

In the PMU Connection Tester, under 'Connection Parameters', try setting it to UDP, port 8850, and then under 'Configure Alternate Command Channel', set that to TCP, with 'Host IP' set to localhost and the port 8950.

Developer
May 22, 2012 at 4:21 PM

Still no go. Im not sure what I am doing wrong.

Everytime it says that the 'machine has actively refused it'

My output stream is enabled for sure. Is there anyway to test to see if it is actually outputing anything?

Could there be anything wrong with the settings on the openPDC side?

I have tried creating the 'Test Stream' from the openPDC documentation and then using the example test stream connection that comes with the PMU Connection tester but this does not work either. It seems to me that this should have worked because I followed the example online explicitly.

Any suggestions?

Kevin

Coordinator
May 22, 2012 at 4:45 PM

Hi Kevin,

Have you tried using the Initialize button on the Output Streams page to initialize your new output stream?

Thanks,
Stephen 

Developer
May 22, 2012 at 4:59 PM

Worked like a charm with the test stream...however still didnt work with my output stream.. i just copied the settings from the connection stream over to my stream and generated the connection and configuration files. I can now see my measurements in openPG. They are still showing N/A right now but I am assuming that they will refresh eventually?

The green dot next to my device (the one streaming from openPDC) is not green. Coudl this be why I am seeing N/A?

 

----------------------

 

Another separate question... How can I make calculated measurements (output measurements of custom adapters) belong to a virtual device so that I can stream those?

Thanks so much!

Kevin

Coordinator
May 23, 2012 at 5:29 PM

Normally you would be seeing N/A if the openPG is not actually receiving the values of those measurements. This could mean that it is not receiving data frames from the openPDC or it is not receiving any data in those data frames. One simple test you could run (if you haven't already) is to connect to the openPDC using the PMU Connection Tester and verify that you are able to see data on the graph. If you are able to see the data, then it is likely a configuration error on the openPG side. In that case, it can also be helpful to run the openPG Console to verify that there are no errors being thrown when trying to connect to the openPDC.

As for your other question, for each measurement generated by your adapters, create a measurement record in the database whose measurement key matches the ones generated by your custom adapter. Then you can define OutputStreamMeasurements associated with those records you defined in the Measurement table.

Stephen