This project has moved and is read-only. For the latest updates, please go here.

Alarm error: No connection could be made because the target machine actively refused it

Jan 30, 2013 at 9:26 PM
Edited Jan 30, 2013 at 9:29 PM
Hello, there
I tried to setup an alarm in openPDC on frequency measurement of an FDR device(just a simple alarm that will trigger if the frequency is greater than 60), but the alarm couldn't work and there is some strange error in "Error Log". The "Exception Message" for "Refresh Alarm" is "No connection could be made because the target machine actively refused it 127.0.0.1:5018".

The port for the device data is 9120. I can see the frequency measurement data on "Graph Measurements" with no problem. And when I used command window to check the status of port 5018, here is the results
netstat -ano | findstr 5018
TCP 127.0.0.1:14809 127.0.0.1:5018 SYN_SENT 7020

tasklist | findstr 7020
openPDCManager.exe 7020 Console 1 152.540K
I don't know what to proceed with this problem. Thank you very much in advance!
Feb 1, 2013 at 4:24 PM
Hello zoeyezhang,

If you type "list /a" on the openPDC console, do you see an adapter called ALARM!SERVICES? If so, please run ConfigurationEditor.exe and look for a section called alarmservicesAlarmService. In that section, there should be a setting called "Endpoints". Can you post the value of that setting?

Thanks,
Stephen
Feb 1, 2013 at 4:59 PM
<div dir="ltr">my two cents: in the configuration editor, I have two entries 'alarmservicesAlarmService', which has 7 values including Endpoints, and 'alarmServicesAlarmService' (note the upper-case 'S') which only has Endpoints, with the same value as the previous entry. Both 'Endpoint's are: http.rest://localhost:5018/alarmservices<br> </div> <div><br> <br> <div>On Fri, Feb 1, 2013 at 11:24 AM, staphen <span dir="ltr">&lt;<a href="mailto:notifications@codeplex.com" target="_blank">notifications@codeplex.com</a>&gt;</span> wrote:<br> <blockquote style="margin:0 0 0 .8ex; border-left:1px #ccc solid; padding-left:1ex"> <div> <p>From: staphen</p> <div>Hello zoeyezhang, If you type &quot;list /a&quot; on the openPDC console, do you see an adapter called ALARM!SERVICES? If so, please run ConfigurationEditor.exe and look for a section called alarmservicesAlarmService. In that section, there should be a setting called &quot;Endpoints&quot;. Can you post the value of that setting? Thanks, Stephen</div> <div> <p>Read the <a href="http://openpdc.codeplex.com/discussions/431470#post995272" target="_blank"> full discussion online</a>.</p> <p>To add a post to this discussion, reply to this email (<a href="mailto:openpdc@discussions.codeplex.com?subject=[openpdc:431470]" target="_blank">openpdc@discussions.codeplex.com</a>)</p> <p>To start a new discussion for this project, email <a href="mailto:openpdc@discussions.codeplex.com" target="_blank"> openpdc@discussions.codeplex.com</a></p> <p>You are receiving this email because you subscribed to this discussion on CodePlex. You can <a href="https://openpdc.codeplex.com/subscriptions/thread/project/edit" target="_blank"> unsubscribe or change your settings</a> on codePlex.com.</p> <p>Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at <a href="http://codeplex.com" target="_blank">codeplex.com</a></p> </div> </div> </blockquote> </div> <br> <br clear="all"> <br> -- <br> Patrick Pentz </div>
Feb 1, 2013 at 7:27 PM
Stephen,
Thank you for answering my question!
I do see alarm!services.
And I saw two entries for "alarmservicesAlarmService". The Endpoints value for the first one is empty, and for the second one is "http.rest://localhost:5018/alarmservices".

Thank you again!

Zoe
Feb 5, 2013 at 4:39 PM
Patrick,
Thanks a lot! I changed the Endpoints value as yours and it works!

Thank you again.

Zoe