This project has moved. For the latest updates, please go here.

The PowerCalculations Action Adapters seen to no longer generate output

Apr 15, 2013 at 2:25 PM
I have been using 3 adapters in the PowerCalculations.dll: PowerCalculator, ReferenceAngle, and ReferenceMagnitude. These no longer produce any output in their measurements. No errors are seen. Has a new parameter become required, or...?
Coordinator
Apr 15, 2013 at 3:42 PM
Hi patpentz,

To my knowledge, those adapters have not been specifically modified for a while. Did this occur after a system upgrade?

Stephen
Apr 15, 2013 at 4:57 PM

The system hasn't bee upgraded recently. I am currently using Alstom's release: 1.5.217. I tried the latest nightly build with the same results. As I said, this used to work, now no output data, and no errors either.


Apr 15, 2013 at 5:22 PM
I just rebuilt the PowerCalculations.dll from openpdc-84048, and set some breakpoints in the initialization routine and in the Status 'get' property. When I reinitialize the adapter, no breakpoints are hit!! I have had no problems setting breakpoints in my private adapters, and expected this to work. Any ideas?


Apr 15, 2013 at 5:32 PM
My previous post was on ReferenceAngle. With PowerCalculator, I get a break on Initialization, but not on PublishFrame. There does seem to be valid data streaming into the input measurements...

I'm also working with Barb Motteler of Alstom on some of these issues...


Apr 15, 2013 at 5:46 PM
I just noticed something very strange: the database representation of PowerCalculation looks correct:
FramesPerSecond=30;LagTime=3;LeadTime=1;OutputMeasurements={PPA:1574;PPA:1575};InputMeasurementKeys={PPA:51;PPA:52;PPA:43;PPA:44};

but in the openPDC Manager the connection strings are from different adapters (in this case, various DynamicCalculation). The type is wrong, also... will restart and see if it changes anything.

no change. Almost as if the display gets frozen when I try to examing a PowerCalculation.

I reinstalled completely this morning, new database, all reinitialized from base.


Apr 15, 2013 at 6:50 PM
Barb has, I believe, solved my problems - lagtime problems. Thanks