This project has moved. For the latest updates, please go here.

Web Service with Multiple IDs

Apr 30, 2013 at 3:14 PM
Edited Apr 30, 2013 at 3:24 PM
Hello,
when I try to use the webservice with a string like this one:

http://localhost:6152/historian/timeseriesdata/read/current/71,72,73,68,69,70,93,99,103,96,100,104,97,101,105,98,102,106,110,111,112,107,108,109,113,132,142,115,135,143,123,140,144,126,141,145,149,150,151,146,147,148,152,159,177,153,162,180,154,168,183,155,171,184,188,189,190,185,186,187,191,202,220,192,205,221,195,211,222,197,214,223/json .

I get the error 400 Bad Request - Invalid URL.
My Question: is there any limit to the amount of IDs I can set? (Removing just 4 IDs I am able to get the timeseriesdata)

I am aware of this discussion: https://openpdc.codeplex.com/discussions/257436 thus I know I could use {FROMID}-{TOID}/json option but this doesn't suit me because I get a long string with many "zeros" (I mean, not-used IDs are returned too).

How can I fix this problem?
ideas:
1.avoid the publication of unused IDs...
2.combination of FROMID-TOID and commas,
3.increase the maximum number of allowed IDs
4.split the url in 2 sub-url would solve the problem but I need to be as fast as possible (and I checked this solution takes more time)

Thanks!
Coordinator
Apr 30, 2013 at 3:54 PM
Browsers (and perhaps the web service) will impose a limit on URL size. However, the web service does support "post" commands which can be of any size.
May 1, 2013 at 10:14 AM
Using the XML configuration editor I changed http.rest://localhost:6152/... in http.soap://localhost:6152/... but how can I get the timeseries data now? Using the browser with the same url address
http://localhost:6152/historian/timeseriesdata/read/current/71/xml I can't get any value. What should I type instead?
Coordinator
May 1, 2013 at 2:41 PM
If you changed it to a SOAP service, REST calls (i.e., URL parameters) will no longer work. With a SOAP service you have to take the WSDL and create a consuming web service - significantly different...

Thanks,
Ritchie