This project has moved and is read-only. For the latest updates, please go here.

openPDC Installation Issue

Apr 27, 2015 at 5:47 PM
At first I thought it was one computer... but when I have the same problem on a second computer, that makes me wonder.

I have 3 Win7 PC's; one of them works with openPDC Manager. The other 2, it won't install. The process gets most of the way through, and then gets rolled back and the install fails. One is my corporate laptop; the other is a very clean PC at home.

I ran verbose logging with the MSI installer, and the log around the error message I'm getting is:

MSI (s) (80:70) [11:32:52:759]: Created Custom Action Server with PID 5108 (0x13F4).
MSI (s) (80:F8) [11:32:52:775]: Running as a service.
MSI (s) (80:F8) [11:32:52:775]: Hello, I'm your 64bit Elevated custom action server.
ExecSecureObjects: Error 0x80070534: failed to get sid for account: openPDC Admins
CustomAction ExecSecureObjects_64 returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 11:32:52: InstallFinalize. Return value 3.

And after this the install gets rolled back.

Any ideas on this one? Thanks!
Apr 27, 2015 at 6:26 PM
Hi Andrew__M,

There appears to be an issue with the MSI where the custom action that creates the "openPDC Admins" group is being skipped if the openPDC service is not installed. If you create the group manually, the installer should work fine. Alternatively, if you don't mind having the service installed locally, you can just go ahead and include it in your installation and the installer should work fine.

Apr 27, 2015 at 6:36 PM
Thanks Stephen - once again, that worked. I didn't really want to install the openPDC service on this computer, just the manager. But, that'll get me going for now. Thanks!