This project has moved and is read-only. For the latest updates, please go here.

PMUConnectionTester Timestamp

Nov 23, 2015 at 12:52 AM

I had a problem about the PMUConnectionTester timestamp. I send the PMU data in C37.118 to one PC and used PMUConnectionTester to test the data. Other data is fine, but the timestamp shown by PMUConnectionTester is leading the actual time from PMU by 5 hrs. I tried all of setting in PMUConnectionTester, but it could not be solved. Moreover, when I selected TRUE for InjectSimulatedTimestamp, the time should be the same as the PC's clock, but it still leaded the PC time by 5 hrs. Where can I set to solve this problem? Thanks.
Nov 23, 2015 at 2:54 PM
Sounds the time source for the GPS clock is set to local time instead of UTC.

Perhaps I am not correctly understanding your scenario...

FYI - all data in the synchrophasor protocol is represented in UTC.

Nov 23, 2015 at 4:22 PM
Hi Ritchie,

Thank you for replying. I think the GPS signals is correct. For example, the timestamp from PMU GPS is 11:19:00.900 AM 11/23/2015. It is the same as my PC's computer, 11:19AM 11/23/2015. However, the time shown on PMUConnectionTester is 2015-11-23 16:19:00:900. This is my problem. I don't know where is wrong.

Nov 23, 2015 at 5:02 PM
Hi liyinbest990,

I believe all of your clocks are correct. The discrepancy you're seeing is the difference between the Eastern time zone and Coordinated Universal Time. The time currently is 12:00 PM Eastern Standard Time and 5:00 PM Coordinated Universal Time, a difference of five hours. The PMU is reporting UTC timestamps to the PMU Connection Tester, as it should, and the PMU Connection Tester is therefore showing you timestamps which appear to be five hours ahead of your local clocks which are all showing you Eastern time.

Nov 23, 2015 at 5:13 PM
Hi Stephen,

Thank you very much. My problem is not only that PMU timestamp is wrong. When I set InjectSimulatedTimestamp as True (PMU Connection Tester will use PC time), the time shown by PMUConnectionTester is still five hours ahead of the PC time (EST). I think the problem is caused by the PMU Connection Tester setting. right? May I set anything to make PMU Tester to show EST timestamp?
Nov 23, 2015 at 5:23 PM
No, the PMU Connection Tester will only display UTC timestamps, and there is no setting to adjust to the local time zone. That also goes for simulated timestamps.
Nov 23, 2015 at 5:26 PM
Hi Stephen,

I appropriate it.